Skip to main content
Where can I learn about ECLI 2.4.0?

Exploring this minor feature release

Philip Johnston avatar
Written by Philip Johnston
Updated over a week ago

🚢 ECLI 2.4.0 has shipped!

We aim for ECLI to be backwards-compatible and work with older versions of P21E, such as the P21E 5.2.x series. But it's best to upgrade to the P21E 5.3.x series to unlock the full potential of ECLI 2.4.0.

If you upgrade to P21E 5.3.1, and want to use ECLI, you need to install ECLI 2.4.0. Meaning, ECLI 2.3.0 and lower are not compatible with the P21E 5.3.x series.

When you're ready, you can download and install ECLI yourself. Note its EULA and always follow your company's policies for installing and running desktop utilities.

LSAF integration clients, download LSAF/ECLI 2.4.0.

📈 6 changes since ECLI 2.3.0

The majority of the changes in ECLI 2.4.0 are backend changes to ensure compatibility with P21E 5.3.1 features, such as the three Object States (Editable, Read-only, Archived) and the naming conventions for (custom) standards and terminologies.

Specifically, ECLI 2.4.0 offers 3 Improvements/Refinements and 3 Bug Fixes. 🐞

For example, you can now:

  • Retrieve the most recent Validation Report XLSX, without having to also upload/validate new data, as you could already do in the P21E GUI

  • Validate against the Define-XML 2.1 standard, as you could already do in the P21E GUI

  • Use the --standard parameter with values in more varied formats, including, e.g., SDTMIG, SDTM, SDTM-IG, SDTM IG.

Assess the full impact and added value for your teams:

👣 What's Next?

Email questions or feedback to

Did this answer your question?